-->
  • Recent Articles

    How to Lock a Package Version in YUM

     How to Lock a Package Version in YUM

    If you want to Lock a version of a Package in YUM then you can do the following Procedure:

    To Lock a Package Version:

    [root@oel7 yum.repos.d]# yum versionlock add 0:python2-futures-3.0.5-1.el7.*

    Loaded plugins: versionlock

    Adding versionlock on: 0:python2-futures-3.0.5-1.el7

    versionlock added: 1

    [root@oel7 yum.repos.d]#

    To Check the Version Locak Status: 

    [root@oel7 yum.repos.d]# yum versionlock status

    Loaded plugins: versionlock

    0:python2-futures-3.0.5-1.el7.*

    versionlock status done

    [root@oel7 yum.repos.d]# 

    To Unlock the YUM Version Lock:

    [root@oel7 yum.repos.d]#  yum versionlock clear

    Loaded plugins: versionlock

    versionlock cleared

    [root@oel7 yum.repos.d]# yum versionlock status

    Loaded plugins: versionlock

    versionlock status done

    [root@oel7 yum.repos.d]#



    No comments